@blog:Name("In a Nutshell.")

/** * @title NPM and Ubuntu 12.04/14.04. Upstream Node.js and NPM. * @date November 6, 2014 * @author Ruslan Ibragimov */

NPM and Ubuntu 12.04/14.04. Upstream Node.js and NPM.

post {

Ubuntu 14.04

На более свежей убунте все решилось еще проще:

sudo apt install nodejs nodejs-legacy npm

Возможно также можно в 12.04.

Node.js сам по себе очень даже ничего, только вот тот факт что парни пакеты не научились собирать удручает.

Ubuntu 12.04

Ок, может я что-то делал не так, но в Ubuntu 12.04.3

npm install

не работает.

Ставился npm и node из репозиториев:

sudo apt install node
sudo apt install npm

Видимо версия слишком старая. Поставим Node.js посвежее:

sudo apt update
sudo apt install -y python-software-properties python g++ make
sudo add-apt-repository ppa:chris-lea/node.js
sudo apt update
sudo apt install nodejs

А теперь всё стало на свои места.

}
comments {
comments powered by Disqus
}